Nwchem problems in Ubuntu 20.04 LTS when it runs in parallel.

Clicked A Few Times
Hi all

I have compiled Nwchem under the new linux Ubuntu-20.04. with Openblas 32 and 64 bit that I have installed from the Ubuntu repository. I have perform some compilation tests with the Openblas 32bit and then 64bit library. Once compiled I did optimization tests on a small molecule (Methylamine)

The program worked correctly in serial mode with 32 and 64 bit openblas library:

$ nwchem methylamine,nw > methylamine.out

Task times cpu: 513.8s wall: 149.9s

But it failed in parallel mode:

$ mpirun -np 8 nwchem methylamine.nw > methylamine.out

The calculation runs indefinitely and I have to stop aborting it. In the output file everything stops at the part that says the following:

                          NWChem Geometry Optimization

                          Methylamine Opt B3LYP/6-31G*

Ubuntu 20.04 LTS

gcc version 9.3.0
gfortran version 9.3.0
libopenmpi version 4.0.3
libopenblas, libopenblas64 serial and parallel version 0.3.8

Forum Vet
One cause of this behavior might be the incompatibility between mpirun and the MPI libraries used during the compilation ... Can you verify that?

Clicked A Few Times
Problem solved

I have added at /home/manager/.profile the following three lines:


And the problem gone.

This is the times for serial run:
Total times  cpu:      523.7s     wall:      148.2s

This is the times for parallel run with "mpirun -np 8"
Total times  cpu:       45.8s     wall:       49.1s

Best Regards...

Forum >> NWChem's corner >> Compiling NWChem